Arcooda Cab Views 2 to 4 play in Slow Motion. View 1 fine - Build 1.70.18 (5th June)

SilverBalls

New member
Apr 12, 2012
1,231
1
I managed to get back home for half a day this morning to do a quick test of the new Arcooda build '1.70.18 Cab' (4th June) on my desktop PC.

CORRECTION: There is a massive performance issue with views 1 to 3 but not the 'flat' view 4. The ball appears to move in slow motion.
I am using a high-end graphics card and PC.

Here is a video showing this:
https://www.youtube.com/watch?v=c181BqWMOSQ

0-35 seconds - View 4 (Flat) - Speed Normal
35s to 1m 20s - Switch to View 3 - Slow Motion Ball (also same for views 1 to 3)
1m20sec to End - Switch Back to View 4 (Flat) - Speed Normal

Specs:
* Windows 7 64-bit
* nVidia GTX 1060 6GB
* Core i5-2400 - 8GB RAM
 
Last edited:

BostonBuckeye

Member
May 3, 2014
183
0
I am not noticing any performance issues at all with each of the 4 camera angles. Running silky smooth for me and my graphics card is not nearly as powerful as yours. I have a nVidia GTX 960 6GB. I have the same CPU as you have. I am running Windows 10 however.
 

GAH1068

New member
Mar 6, 2018
181
0
I saw the same issues a few times yesterday while playing with the new views. Not nearly as bad but my processor is probably the reason why it isn't as pronounced. I have a high-end system as well Core I7-8700, GTX1080,16gb RAM, and Windows 10 Pro.

It isn't constant but there were a few times where the flipper or ball would just slow down or pause for a second or two. It wasn't constant so I thought it might might have been some sort of background
process on my system. I was using view 2 as well.
 
Last edited:

GAH1068

New member
Mar 6, 2018
181
0
Could you take screen print of you TPAConfig settings for DX11. Might be something in there, I haven't had time to check.

Sorry - didn't see you already had them in there!
 
Last edited:

MadAxeMan

New member
Jan 31, 2014
200
0
I'm experiencing similar slow downs, except my flat view is view #4
Slow down for me, was with the new views #1-3
but I found the slowdown to be slight, but noticeable

Specs:
*Windows 10 64bit
*GTX 670 - 2gb
*AMD quad core - 8gb

I was thinking I was probably gonna need to step up my GPU
perhaps a used GTX 970? (never mind, I see someone has a gtx1080 in theirs)
I wonder what Farsight has in their Arcooda machine....
 
Last edited:

GAH1068

New member
Mar 6, 2018
181
0
I'm experiencing similar slow downs, except my flat view is view #4
Slow down for me, was with the new views #1-3
but I found the slowdown to be slight, but noticeable

Specs:
*Windows 10 64bit
*GTX 670 - 2gb
*AMD quad core - 8gb

I was thinking I was probably gonna need to step up my GPU
perhaps a used GTX 970? (never mind, I see someone has a gtx1080 in theirs)
I wonder what Farsight has in their Arcooda machine....

I heard on Blahcade pod cast they are using a GTX970 or GTX980. I know it was a GTX9XX series though for GPU. I am going to change my DX11 settings tonight as I might have caused the issue myself when I was running TPAConfig
 

SilverBalls

New member
Apr 12, 2012
1,231
1
I'm experiencing similar slow downs, except my flat view is view #4
Slow down for me, was with the new views #1-3
but I found the slowdown to be slight, but noticeable

Specs:
*Windows 10 64bit
*GTX 670 - 2gb
*AMD quad core - 8gb

I was thinking I was probably gonna need to step up my GPU
perhaps a used GTX 970? (never mind, I see someone has a gtx1080 in theirs)
I wonder what Farsight has in their Arcooda machine....


I might have got the view number wrong (as I couldn't see the number anywhere), but it was the 3 non-flat views that were slow.

It doesn't seem to make sense because if I run the DX11 version all views are super smooth, but in the cabinet build only the flat view is smooth. Must be some kind of bug specific to cabinet mode, maybe Farsight can try it and see if the FPS drops for those views.

I also tried Fullscreen, Windowed, Disabling Desktop Compositon in Win7, etc.
 

vfpcoder

Member
Jul 9, 2012
302
0
Thanks for video. Looks like it works good for you. Once you turn that room brightness down and bulbs up in the settings, will look awesome ;)

Thanks! I’ve got to tell you that I’m enjoying the heck out of this cabinet mod — and that’s even with the issues regarding the plunger and the five tables that are currently not fully implemented in two monitor mode. The thing is, I feel confident at this point that FarSight will get these issues corrected.

But I’ve got to say that it seems very odd that you’re experiencing a slowdown on some of the new cabinet camera views when I am not. You obviously have a much more powerful system.
 

MadAxeMan

New member
Jan 31, 2014
200
0
I'm still getting the view # on the bottom left of the play field

#1-3 = 48-51fps
#4 = 60fps

I'm going to try change going some of the DX11 settings.


------

My room/bulb brightness was:
10% room
100% bright

lately, I've been trying to get the playfield some what go with the backglass
35% room
30% bulb
 

Jamman39

New member
Jan 1, 2013
246
0
I'm sure that this is a dumb question but what settings are there in PBA that I can adjust? I see a couple things to do with MSAA in the launch configuration menu, but not much else
 

SilverBalls

New member
Apr 12, 2012
1,231
1
I'm still getting the view # on the bottom left of the play field

#1-3 = 48-51fps
#4 = 60fps

I'm going to try change going some of the DX11 settings.


------

My room/bulb brightness was:
10% room
100% bright

lately, I've been trying to get the playfield some what go with the backglass
35% room
30% bulb

Thanks for checking. I am away from home again, but I got my son to check and it is view 4 (the flat one) that is the only one that plays smooth. I update my first post.
 

MadAxeMan

New member
Jan 31, 2014
200
0
I'm still getting the view # on the bottom left of the play field

#1-3 = 48-51fps
#4 = 60fps

I'm going to try change going some of the DX11 settings.


------

My room/bulb brightness was:
10% room
100% bright

lately, I've been trying to get the playfield some what go with the backglass
35% room
30% bulb
Update:
I tried lowering the few DX11 settings to minimum, and only gained 2fps vs max settings, still felt slow.
I've always assumed the DX9 settings were independent from DX11 version

Hopefully, Farsight has a GTX970 in theirs, cheaper :)
 

SilverBalls

New member
Apr 12, 2012
1,231
1
Update:
I tried lowering the few DX11 settings to minimum, and only gained 2fps vs max settings, still felt slow.
I've always assumed the DX9 settings were independent from DX11 version

Hopefully, Farsight has a GTX970 in theirs, cheaper :)

I also tried lowering the graphic settings this morning, but it also didn't improve the performance with views 1 to 3.

I would imagine the slow down for the views 1 to 3 is a bug because at the end of the day the camera isn't moving around he table. Our graphic cards are pretty powerful and should be able to handle it. I didn't get any issues with the various camera angles I used in the FreeCamMod so hoping Farsight can fix this.

I did my test on a desktop but my Pinball Cabinet has a different PC/Graphics card but I won't be re-united with that for a couple or weeks to try it out unfortunately..
 

Jamman39

New member
Jan 1, 2013
246
0
I'm sure it's just a bug, Farsight's Steam page recommends a GTX 560 or higher. I did get a big performance improvement by starting a game and killing Steam with the task manager.
 

Narc0lep5y

Member
Feb 21, 2015
311
0
I'm getting performance hits in 2 screen mode as well. ST TNG was the best running table but i can't remember what view it was. My cabinet test machine is a W10, Core 2 Quad Q6600 and 750ti GPU 8GB Ram, but it's never had any issues on the freecameramod before and runs Pinball FX2 and 3 cabinet modes like a champ. If i'm getting the same slowdown as you guys with 1060 and core iseries processors then that's got to be software optimization issues. If it was a hardware thing my hardware would make it unplayable.
 

SilverBalls

New member
Apr 12, 2012
1,231
1
I'm getting performance hits in 2 screen mode as well. ST TNG was the best running table but i can't remember what view it was. My cabinet test machine is a W10, Core 2 Quad Q6600 and 750ti GPU 8GB Ram, but it's never had any issues on the freecameramod before and runs Pinball FX2 and 3 cabinet modes like a champ. If i'm getting the same slowdown as you guys with 1060 and core iseries processors then that's got to be software optimization issues. If it was a hardware thing my hardware would make it unplayable.

Will be good to hear from Farsight or Arcooda at least to say it is being looked at.
 

L33

New member
Aug 20, 2014
418
0
Same issue here. I’m running gtx 960 or 970. Can’t remember which. Tried first game STTNG and I think it was 23fps? Really slow and not playable. My concern is the time they have for fixing the issues. I’m gonna give it a couple of days then I feel I have no choice but to ask for a refund as whilst I’ve been longing for cab support I don’t want to pay for something that only slightly resembles cab support and comes with little support. Another concern is if this issue is fixed, what happens if future steam/FarSight updates cause more problems.
 
Top