Dmd not working anymore, stays black

joyrider3774

New member
May 3, 2019
4
0
Hey,

I'm not sure what happened but pinball arcade (1.71.25) with freecammod was working fine a few weeks ago but today when i tried to play it i noticed the window where normally the dmd would appear stays black on all tables so i'm not sure what happend. My freecammod is still the latest lastest version and as far as i'm aware there were no updates for pinball arcade anymore but i'm not certain of this. Is anyone having the same issue or knows what could be causing this ? The mod itself with the cam files still seems to work but the dmd just stays black for some reason. Thanks (ps i'm using the virtual dmd window not a real dmd if that matters)
 

curtis

New member
Aug 30, 2015
110
0
Hello! My cabinet + FreeCamMod still works fine. So, my guess is that it's a Windows related issue. Maybe you could try re-installing the .NET framework (4.5.2).
 

curtis

New member
Aug 30, 2015
110
0
Curtis I try to reinstall .NET 4.52 but windows doesnt install.

I'm still using Windows7 for my pinball cabinet. If you have a newer version of Windows, you may try to install a newer .NET framework. Version 4.8 is the latest.
 

joyrider3774

New member
May 3, 2019
4
0
curtis are you using an offline data file / is your cab connected to the internet and are you using latest steam versions of pinball arcade ? i'm having the same problem as halen maybe a windows 10 update broke something if it's still working on your windows 7.
 

curtis

New member
Aug 30, 2015
110
0
curtis are you using an offline data file / is your cab connected to the internet and are you using latest steam versions of pinball arcade ? i'm having the same problem as halen maybe a windows 10 update broke something if it's still working on your windows 7.
No offline mode, as I'm connected to the internet; and I'm using the latest Steam version.
 

joyrider3774

New member
May 3, 2019
4
0
i just tried on my main pc (not cabinet) which is also a windows 10 and latest freecam mod and version of pinball arcade and it's having the same problem.

Unfortunatly i don't have a windows 7 pc anymore so i can not test it but it is possible it's a windows 10 issue then if it's still working on your windows 7 pc

Edit: i can't get it to work, so i have reverted to disabling cabinet mode (could not get the ingame hud to display otherwise somehow not sure, could also be it started working again when setting the disable ingame hud to the other value inside the ini) and loading a backglass myselve using self created tool and passing the table parameter to launch before script, but i do use the camera mod. So basically reverted to ingame dmd on the playfield and using freecam mod to launch the game and do the camera stuff but nothing else
 
Last edited:

2huwman

New member
Apr 16, 2020
4
0
I've had the same issue (my PC is Win 10 pro 64, TPA 1.70.6). The DMD worked fine until I upgraded my GPU from an NVIDIA GT 630 to a Radeon RX590. I just get a black rectangle with the Radeon, but a working DMD when I swap back to the NVIDIA card. Anyone got any ideas on a fix?
 

NoEx

New member
Mar 12, 2015
328
0
I've investigated a bit about this issue with windows 10 and I've discovered that for an unknown reason, since a few months (caused by a windows update???), the part of the game window which contain the DMD isn't rendered anymore when it's oversized outside of the screen, this was the hacky method I used to hide/display the DMD and it was working flawlessly until now.

The only fix I think of would be to set your monitors like this:



This way, the top part of the game's window which is oversized to hide the DMD isn't displayed in the "void" but on the backglass monitor, and the DMD should be rendered correctly by the mod.
 

nanuk

New member
Sep 6, 2013
14
0
I've had the same issue (my PC is Win 10 pro 64, TPA 1.70.6). The DMD worked fine until I upgraded my GPU from an NVIDIA GT 630 to a Radeon RX590. I just get a black rectangle with the Radeon, but a working DMD when I swap back to the NVIDIA card. Anyone got any ideas on a fix?

running windows 10 pro with a nvidia gtx 960 an got the black dmd to im about to tru NoEx idea
 

nanuk

New member
Sep 6, 2013
14
0
I've investigated a bit about this issue with windows 10 and I've discovered that for an unknown reason, since a few months (caused by a windows update???), the part of the game window which contain the DMD isn't rendered anymore when it's oversized outside of the screen, this was the hacky method I used to hide/display the DMD and it was working flawlessly until now.

The only fix I think of would be to set your monitors like this:



This way, the top part of the game's window which is oversized to hide the DMD isn't displayed in the "void" but on the backglass monitor, and the DMD should be rendered correctly by the mod.
this id the trick thanx a lot but did screw up my backglass for my FP table so got to find how to fix that now but thx a lot to find the prob for your mod
 

Sebinouse

Member
Jul 18, 2012
99
0
The only fix I think of would be to set your monitors like this:



This way, the top part of the game's window which is oversized to hide the DMD isn't displayed in the "void" but on the backglass monitor, and the DMD should be rendered correctly by the mod.

You mean the DMD mask on the back glass should be at its actual rendering position. If we have a 3 monitor setup, should we do the same ? DMD on top of play field ?

I’ve found several discussions on «*script for Display Arrangement «* ... we may be able to create the right script to make it work with FP, VP, PFX3 ... and Arcooda.

Links :

https://superuser.com/questions/394...rangement-via-batch-command-line-on-windows-7

http://12noon.com/?page_id=80

https://wizardsoft.nl/products/wsdisplaysettings
 

NoEx

New member
Mar 12, 2015
328
0
You mean the DMD mask on the back glass should be at its actual rendering position. If we have a 3 monitor setup, should we do the same ? DMD on top of play field ?

I’ve found several discussions on «*script for Display Arrangement «* ... we may be able to create the right script to make it work with FP, VP, PFX3 ... and Arcooda.

Links :

https://superuser.com/questions/394...rangement-via-batch-command-line-on-windows-7

http://12noon.com/?page_id=80

https://wizardsoft.nl/products/wsdisplaysettings

It doesn't matter which monitor is placed above playfield; in fact you can arrange it how you want (I guess.. I haven't tried every scenario, make some tests but it should work), the only important thing is : there must be a monitor above playfield, to allow the DMD being rendered properly, then the mod does its job, it displays the dmd in a movable frame that you can place anywhere you want.
 

thebeast0449

New member
Jul 8, 2019
4
0
I have a similar problem
I solved it last time by doing what has been suggested by manipulating the top screens position
on my setup the top tv had to be hard left in line with the bottom screen for the
floating dmd to line up right.

this time however I am getting no change as I move the top monitor about
the floating DMD does not change and remains cut in half.
(half has working DMD other half is greyed out)
also it is HUGE as its default size
everything else is perfect - just the DMD image is cut in half

I am using 4k - If I use the recommended settings 2160 x 4400 the screen is short both ends
I set it to 2160 x 5000 in TPA and the PF is perfect
(*with 1080p PC PF) and yeah I tried setting it to 4400 on TPA to see If DMD corrected.
no change
It seems as If nothing will change the floating DMD exempt changing the PF res on the PC
which I do not want to mess with

please HELP!

ps - thankyou so much for this amazing mod.
#respect
thankyou all
 
Last edited:

thebeast0449

New member
Jul 8, 2019
4
0
ok - got it working

I had to enter the correct stretching values and disable 4k support
the DMD window changed to a perfect fit
I dont really geddit but its working so..
 

thebeast0449

New member
Jul 8, 2019
4
0
this worked for me-

disable 4K support in mod settings

Setting up your PC:
The resolution of the playfield display must be set to 1080x1920

Setting up the Game:
The game settings will require that the Back buffer width and Back buffer height maintain the same ratio as the default settings for the mod. Though the values recommended aren’t listed in the drop down menu, you can select each box and manually enter the proper values. These are required and valid: 2160x4400 (default)

Setting up the Mod:
WindowStretch=586 This is the default value for proper aspect ratio. I Recommend not changing if you’re using a 1080x1920 display for playfield.

what does the 4K support check actually do?
 

Members online

No members online now.

Members online

No members online now.

Latest posts

Latest posts

Top